请选择 进入手机版 | 继续访问电脑版

Websoft9技术社区(旧版)

 找回密码
 立即注册
查看: 604|回复: 1

wampserver出现You don’t have permission to access

[复制链接]

5

主题

10

帖子

30

积分

新手上路

Rank: 1

积分
30
发表于 2016-12-9 17:31:46 | 显示全部楼层 |阅读模式
            这些天都在都遇到wampserver提示出现:You don't have permission to access/on this server.的提示,一直没去解决。今天由于网站开始改版得用到wamp,所以就得搞定这个问题了。
        本地搭建wamp,输入http://127.0.0.1访问正常,当输入http://localhost/,apache出现You don't have permission to access/on this server.的提示,如何解决?
  •                 找到httpd.conf,用记事本打开httpd.conf,然后将
        
  •                         <Directory />
  •                             Options FollowSymLinks
  •                             AllowOverride None
  •                             Order deny,allow
  •                             Deny from all
  •                         </Directory>

        这里改成:

        
  •                         <Directory />
  •                             Options FollowSymLinks
  •                             AllowOverride None
  •                             Order deny,allow
  •                             Allow from all
  •                         </Directory>

        还有一处将下面

        
  •                         # onlineoffline tag - don't remove
  •                         Order Deny,Allow
  •                         Deny from all  
  •                         Allow from 127.0.0.1
  •                         </Directory>

       将Deny from all  改为:Allow from all  ,然后重新启动所有服务。

        现在打开localhost或127.0.0.1时发现可以访问了,但访问phpmyadmin时候,出现“You don't have permission to access /phpmyadmin/ on this server.”的提示。
  •                 解决方法,打开如下文件:
        

                C:/wamp/alias/phpmyadmin.conf    //注意,你wamp的安装目录可能不同,用编辑器打开

        修改成这样:

        
  •                         <Directory "c:/wamp/apps/phpmyadmin3.5.1/">
  •                             Options Indexes FollowSymLinks MultiViews
  •                             AllowOverride all
  •                                 Order Deny,Allow
  •                             Allow from all
  •                             Allow from 127.0.0.1
  •                         </Directory>

        修改保存后,一定要记得重启wampserver哟。接下来就应该搞定了吧。

   

回复

使用道具 举报

284

主题

396

帖子

1584

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1584
发表于 2017-5-11 11:18:53 | 显示全部楼层
如果是websoft9的wamp镜像,修改C:\websoft9\wampstack版本号\apache2\conf下的
<Directory />
    AllowOverride none
    Require all denied
</Directory>



<Directory />
                            Options FollowSymLinks
                            AllowOverride None
                            Order deny,allow
                            Allow from all
</Directory>


然后重启APACHE服务。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

websoft9人工服务,助力企业快速上云

QQ|官网首页|站点统计|Archiver|手机版|小黑屋|Websoft9技术社区(旧版) ( 湘ICP备16009117号

GMT+8, 2017-7-26 20:37 , Processed in 0.016161 second(s), 7 queries , File On.

Powered by Discuz! X3.3

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表